CVE-2019-10785GHSA-PG97-WW7H-5MJRSNYK-JS-DOJOX-548257,
dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.11.9, 1.12.7, 1.13.6, 1.14.5, 1.15.2, and 1 more
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
dojox is vulnerable to Cross-site Scripting in all versions before version 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7 and 1.11.9. This is due to dojox.xmpp.util.xmlEncode only encoding the first occurrence of each character, not all of them.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a dojox
Version range not reported
- dojoxnpm
fixed in 1.11.9
- dojoxnpm
From 1.12.0 · fixed in 1.12.7
- dojoxnpm
From 1.13.0 · fixed in 1.13.6
- dojoxnpm
From 1.14.0 · fixed in 1.14.5
- dojoxnpm
From 1.15.0 · fixed in 1.15.2
- dojoxnpm
From 1.16.0 · fixed in 1.16.1