CVE-2019-10766GHSA-68WG-QV6R-J4VPSNYK-PHP-USMANHALALITPIXIE-534879
Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.0.3, 2.0.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Pixie versions 1.0.x before 1.0.3, and 2.0.x before 2.0.2 allow SQL Injection in the limit() function due to improper sanitization.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Pixie Query Builder
Version range not reported
- usmanhalalit/pixiePackagist
fixed in 1.0.3
- usmanhalalit/pixiePackagist
From 2.0.0 · fixed in 2.0.2