Skip to main content
← All vulnerabilities
CVE-2019-10752GHSA-M9JW-237R-GVFV

Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escap

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 4.44.3, 5.15.1
None on Exploit-DB, Metasploit or GitHub

Summary

Sequelize, all versions prior to version 4.44.3 and 5.15.1, is vulnerable to SQL Injection due to sequelize.json() helper function not escaping values properly when formatting sub paths for JSON queries for MySQL, MariaDB and SQLite.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a sequelize

    Version range not reported

  • sequelizenpm

    fixed in 4.44.3

  • sequelizenpm

    From 5.0.0 · fixed in 5.15.1

References 3

GitHub · sequelize/sequelize

snyk.io