CVE-2019-10748GHSA-J9XP-92VC-559JSNYK-JS-SEQUELIZE-450221
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.35.1, 4.44.3, 5.8.11
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Sequelize all versions prior to 3.35.1, 4.44.3, and 5.8.11 are vulnerable to SQL Injection due to JSON path keys not being properly escaped for the MySQL/MariaDB dialects.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Sequelize
All versions prior to 3.35.1, All versions prior to 4.44.3, All versions prior to 5.8.11
- sequelizenpm
fixed in 3.35.1
- sequelizenpm
From 4.0.0 · fixed in 4.44.3
- sequelizenpm
From 5.0.0 · fixed in 5.8.11