Skip to main content
← All vulnerabilities
CVE-2019-10241GHSA-7VX9-XJHR-RW6H

In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote cl

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.2.27.v20190403, 9.3.26.v20190403, 9.4.16.v20190411
None on Exploit-DB, Metasploit or GitHub

Summary

In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • The Eclipse Foundation Eclipse Jetty

    through 9.2.26; through 9.3.25; through 9.4.15

  • org.eclipse.jetty:jetty-serverMaven

    fixed in 9.2.27.v20190403

  • org.eclipse.jetty:jetty-serverMaven

    From 9.3.0 · fixed in 9.3.26.v20190403

  • org.eclipse.jetty:jetty-serverMaven

    From 9.4.0 · fixed in 9.4.16.v20190411

References 15

lists.apache.org

oracle.com

security.netapp.com

bugs.eclipse.org

lists.debian.org

debian.org