Skip to main content
← All vulnerabilities
CVE-2019-10206PYSEC-2019-145GHSA-CQMR-RCPR-CXH3

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt pass

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.19, 2.7.13, 2.8.4
None on Exploit-DB, Metasploit or GitHub

Summary

ansible-playbook -k and ansible cli tools, all versions 2.8.x before 2.8.4, all 2.7.x before 2.7.13 and all 2.6.x before 2.6.19, prompt passwords by expanding them from templates as they could contain special characters. Passwords should be wrapped to prevent templates trigger and exposing them.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat Ansible

    all 2.8.x before 2.8.4, all 2.7.x before 2.7.13, all 2.6.x before 2.6.19

  • ansiblePyPI

    From 2.6.0 · fixed in 2.6.19; From 2.7.0 · fixed in 2.7.13; From 2.8.0 · fixed in 2.8.4

  • ansiblePyPI

    From 2.8.0 · fixed in 2.8.4

  • ansiblePyPI

    From 2.7.0 · fixed in 2.7.13

  • ansiblePyPI

    From 2.6.0 · fixed in 2.6.19

References 5

lists.opensuse.org

debian.org

bugzilla.redhat.com

lists.debian.org