CVE-2019-10156GHSA-GRGM-PPH5-J5H7PYSEC-2019-2
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.6.18, 2.7.12, 2.8.2
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat ansible
fixed in 2.6.18, fixed in 2.7.12, fixed in 2.8.2
- ansiblePyPI
fixed in 2.6.18
- ansiblePyPI
From 2.7.0a1 · fixed in 2.7.12
- ansiblePyPI
From 2.8.0a1 · fixed in 2.8.2
- ansiblePyPI
fixed in 2.6.18; From 2.7.0 · fixed in 2.7.12; From 2.8.0 · fixed in 2.8.2