CVE-2019-10134GHSA-J8WR-7XXJ-C2FR
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.4, 3.5.6, 3.4.9, 3.1.18
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The size of users' private file uploads via email were not correctly checked, so their quota allowance could be exceeded.
Timeline
- CVE published
- Record last updated
Affected versions
- Moodle moodle
Version range not reported
- moodle/moodlePackagist
From 3.6 · fixed in 3.6.4
- moodle/moodlePackagist
From 3.5 · fixed in 3.5.6
- moodle/moodlePackagist
From 3.4 · fixed in 3.4.9
- moodle/moodlePackagist
From 3.1 · fixed in 3.1.18