CVE-2019-10133GHSA-5XP2-RV4H-MM2Q
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.4, 3.5.6, 3.4.9, 3.1.18
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in Moodle before 3.7, 3.6.4, 3.5.6, 3.4.9 and 3.1.18. The form to upload cohorts contained a redirect field, which was not restricted to internal URLs.
Timeline
- CVE published
- Record last updated
Affected versions
- Moodle moodle
Version range not reported
- moodle/moodlePackagist
From 3.6.0 · fixed in 3.6.4
- moodle/moodlePackagist
From 3.5.0 · fixed in 3.5.6
- moodle/moodlePackagist
From 3.4.0 · fixed in 3.4.9
- moodle/moodlePackagist
fixed in 3.1.18