Skip to main content
← All vulnerabilities
CVE-2019-10094GHSA-MM7M-XG4H-6M52

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.22
None on Exploit-DB, Metasploit or GitHub

Summary

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Apache Tika

    1.7 to 1.21

  • org.apache.tika:tika-coreMaven

    From 1.7 · fixed in 1.22

References 7

lists.apache.org

oracle.com