Skip to main content
← All vulnerabilities
CVE-2019-10088GHSA-MFWH-GQX8-C787

A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.22
None on Exploit-DB, Metasploit or GitHub

Summary

A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Apache Tika

    1.7 to 1.21

  • org.apache.tika:tika-coreMaven

    From 1.7 · fixed in 1.22

References 8

lists.apache.org

security.netapp.com

oracle.com