CVE-2019-1003001GHSA-6Q78-6XVR-26FG
A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlo
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.61.1, 1.3.4.1, 1.50
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 3 on Exploit-DB, 1 Metasploit module
Summary
A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in src/main/java/org/jenkinsci/plugins/workflow/cps/CpsFlowDefinition.java, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShellFactory.java that allows attackers with Overall/Read permission to provide a pipeline script to an HTTP endpoint that can result in arbitrary code execution on the Jenkins master JVM.
Timeline
- CVE published
- Public exploit on Exploit-DB
EDB-46427, EDB-46572, EDB-46572
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Jenkins project Pipeline: Groovy Plugin
Version range not reported
- org.jenkins-ci.plugins.workflow:workflow-cps-parentMaven
fixed in 2.61.1
- org.jenkins-ci.plugins:pipeline-model-definitionMaven
fixed in 1.3.4.1
- org.jenkins-ci.plugins:script-securityMaven
fixed in 1.50