Skip to main content
← All vulnerabilities
CVE-2019-1002100GHSA-Q4RR-64R9-FWGFGO-2023-1946

In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Se

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in v1.11.8, v1.12.6, v1.13.4, 1.11.8, 1.12.6, and 1 more
None on Exploit-DB, Metasploit or GitHub

Summary

In all Kubernetes versions prior to v1.11.8, v1.12.6, and v1.13.4, users that are authorized to make patch requests to the Kubernetes API Server can send a specially crafted patch of type "json-patch" (e.g. `kubectl patch --type json` or `"Content-Type: application/json-patch+json"`) that consumes excessive resources while processing, causing a Denial of Service on the API Server.

Timeline

  1. CVE published
  2. Record last updated
  3. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Kubernetes Kubernetes

    fixed in v1.11.8; fixed in v1.12.6; fixed in v1.13.4

  • k8s.io/kubernetesGo

    From 1.0.0 · through 1.10.14

  • k8s.io/kubernetesGo

    From 1.11.0 · fixed in 1.11.8

  • k8s.io/kubernetesGo

    From 1.12.0 · fixed in 1.12.6

  • k8s.io/kubernetesGo

    From 1.13.0 · fixed in 1.13.4

  • k8s.io/kubernetesGo

    From 1.0.0 · fixed in 1.11.8; From 1.12.0 · fixed in 1.12.6; From 1.13.0 · fixed in 1.13.4

References 6

securityfocus.com

groups.google.com

GitHub · kubernetes/kubernetes

security.netapp.com

access.redhat.com