Skip to main content
← All vulnerabilities
CVE-2019-0194GHSA-4WJQ-69RC-8WCP

Apache Camel's File is vulnerable to directory traversal.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.21.5, 2.22.3, 2.23.1
None on Exploit-DB, Metasploit or GitHub

Summary

Apache Camel's File is vulnerable to directory traversal. Camel 2.21.0 to 2.21.3, 2.22.0 to 2.22.2, 2.23.0 and the unsupported Camel 2.x (2.19 and earlier) versions may be also affected.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Apache Camel

    Camel 2.21.0 to 2.21.3

  • org.apache.camel:camel-coreMaven

    From 2.21.0 · fixed in 2.21.5

  • org.apache.camel:camel-coreMaven

    From 2.22.0 · fixed in 2.22.3

  • org.apache.camel:camel-coreMaven

    From 2.23.0 · fixed in 2.23.1

References 9

lists.apache.org

openwall.com

securityfocus.com