CVE-2018-9861GHSA-G78H-PF65-46RVDRUPAL-CORE-2018-003
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 8.5.2, 4.9.2, 8.4.7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Cross-site scripting (XSS) vulnerability in the Enhanced Image (aka image2) plugin for CKEditor (in versions 4.5.10 through 4.9.1; fixed in 4.9.2), as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, allows remote attackers to inject arbitrary web script through a crafted IMG element.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- drupal/corePackagist
From 8.5.0 · fixed in 8.5.2
- ckeditor-devnpm
From 4.5.10 · fixed in 4.9.2
- drupal/corePackagist
From 8.0 · fixed in 8.4.7
- drupal/drupalPackagist
From 8.0 · fixed in 8.4.7
- drupal/drupalPackagist
From 8.5 · fixed in 8.5.2
- drupal/corePackagist
From 8.0.0 · fixed in 8.4.7; From 8.5.0 · fixed in 8.5.2