CVE-2018-8041GHSA-JV74-F9PJ-XP3F
Apache Camel's Mail 2.20.0 through 2.20.3, 2.21.0 through 2.21.1 and 2.22.0 is vulnerable to path traversal.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.20.4, 2.21.2, 2.22.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 1 proof of concept on GitHub
Summary
Apache Camel's Mail 2.20.0 through 2.20.3, 2.21.0 through 2.21.1 and 2.22.0 is vulnerable to path traversal.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Camel
Version range not reported
- org.apache.camel:camel-mailMaven
From 2.20.0 · fixed in 2.20.4
- org.apache.camel:camel-mailMaven
From 2.21.0 · fixed in 2.21.2
- org.apache.camel:camel-mailMaven
From 2.22.0 · fixed in 2.22.1