Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because o
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Listed in CISA KEV
- Fix
- Fixed in 8.3.9, 8.4.6, 8.5.1, 7.58
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Drupal, a widely used open-source content management system, is affected by this vulnerability. An attacker located remotely could exploit it to run arbitrary code on the affected website's server, potentially taking full control of the system.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1 allows remote attackers to execute arbitrary code because of an issue affecting multiple subsystems with default or common module configurations.
Timeline
- CVE published
- Added to CISA KEV
CISA has evidence of exploitation in the wild
- CISA remediation deadline
Due date for US federal agencies to patch
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- n/a Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1
Drupal before 7.58, 8.x before 8.3.9, 8.4.x before 8.4.6, and 8.5.x before 8.5.1
- drupal/corePackagist
From 8.0.0 · fixed in 8.3.9; From 8.4.0 · fixed in 8.4.6; From 8.5.0 · fixed in 8.5.1
- drupal/corePackagist
From 7.0 · fixed in 7.58
- drupal/corePackagist
From 8.0 · fixed in 8.3.9
- drupal/corePackagist
From 8.4.0 · fixed in 8.4.6
- drupal/corePackagist
From 8.5.0 · fixed in 8.5.1
- drupal/drupalPackagist
From 7.0 · fixed in 7.58
- drupal/drupalPackagist
From 8.0 · fixed in 8.3.9
- drupal/drupalPackagist
From 8.4 · fixed in 8.4.6
- drupal/drupalPackagist
From 8.5 · fixed in 8.5.1