Skip to main content
← All vulnerabilities
CVE-2018-7577GHSA-QX2V-J445-G354PYSEC-2019-207PYSEC-2019-225PYSEC-2019-232

Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from oth

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.7.1
None on Exploit-DB, Metasploit or GitHub

Summary

Memcpy parameter overlap in Google Snappy library 1.1.4, as used in Google TensorFlow before 1.7.1, could result in a crash or read from other parts of process memory.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • tensorflowPyPI

    From 1.1.0 · fixed in 1.7.1

  • tensorflow-gpuPyPI

    From 1.1.0 · fixed in 1.7.1

  • tensorflow-gpuPyPI

    fixed in 1.7.1

  • tensorflow-cpuPyPI

    fixed in 1.7.1

  • tensorflowPyPI

    fixed in 1.7.1

References 1

GitHub · tensorflow/tensorflow