Skip to main content
← All vulnerabilities
CVE-2018-6519GHSA-HHM8-2J4G-MPGG

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerab

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.10.4, 2.3.5, 3.1.1
None on Exploit-DB, Metasploit or GitHub

Summary

The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • simplesamlphp/saml2Packagist

    fixed in 1.10.4

  • simplesamlphp/saml2Packagist

    From 2.0 · fixed in 2.3.5

  • simplesamlphp/saml2Packagist

    From 3.0 · fixed in 3.1.1

References 2

simplesamlphp.org

debian.org