CVE-2018-3760GHSA-PR3H-JJHJ-573X
There is an information leak vulnerability in Sprockets.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.7.2, 4.0.0.beta8, 2.12.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- 4 proofs of concept on GitHub, 1 Nuclei template
Summary
There is an information leak vulnerability in Sprockets. Versions Affected: 4.0.0.beta7 and lower, 3.7.1 and lower, 2.12.4 and lower. Specially crafted requests can be used to access files that exists on the filesystem that is outside an application's root directory, when the Sprockets server is used in production. All users running an affected release should either upgrade or use one of the work arounds immediately.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- HackerOne Sprockets
Version range not reported
- sprocketsRubyGems
From 3.0.0 · fixed in 3.7.2
- sprocketsRubyGems
From 4.0.0.beta1 · fixed in 4.0.0.beta8
- sprocketsRubyGems
fixed in 2.12.5