Skip to main content
← All vulnerabilities
CVE-2018-25050GHSA-X5Q4-M45M-FM94

Harvest Chosen abstract-chosen.coffee AbstractChosen cross site scripting

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Harvest Chosen

    1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4, 1.8.5, 1.8.6

  • harvesthq/chosenPackagist

    fixed in 1.8.7

References 5

vuldb.com

GitHub · harvesthq/chosen