Skip to main content
← All vulnerabilities
CVE-2018-25047GHSA-HWQ7-5VV9-C6CF

In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.47, 4.2.1
None on Exploit-DB, Metasploit or GitHub

Summary

In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • smarty/smartyPackagist

    fixed in 3.1.47

  • smarty/smartyPackagist

    From 4.0.0 · fixed in 4.2.1

References 6

GitHub · smarty-php/smarty

bugs.gentoo.org

security.gentoo.org

lists.debian.org