Skip to main content
← All vulnerabilities
CVE-2018-20804

Invariant failure in applyOps

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.6.13, 4.0.10
None on Exploit-DB, Metasploit or GitHub

Summary

A user authorized to perform database queries may trigger denial of service by issuing specially crafted applyOps invocations. This issue affects MongoDB Server v4.0 versions prior to 4.0.10 and MongoDB Server v3.6 versions prior to 3.6.13.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • MongoDB Inc. MongoDB Server

    From 3.6 · fixed in 3.6.13; From 4.0 · fixed in 4.0.10

References 1

jira.mongodb.org